Results 1 to 6 of 6

Thread: Help me repair a TT850W PSU

  1. #1
    Join Date
    Sep 2008
    Location
    Zagreb, Croatia
    Posts
    5
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default Help me repair a TT850W PSU

    First of all, I want to say hi to everyone.

    I'm from Croatia, Zagreb, and I've got a link to this forum from a regional
    PC forum.
    I hope You can help me out with a problem I have.


    A Thermaltake 850W PSU, Toughpower, and it has a problem.
    when on idle, it behaves good, gives good voltage values, but when plugged in a PC it loses it's grip and gives 3.7V on 5V line, and 4.1V when plugged into a PS tester.
    everyting else is ok except 5V.

    i opened it and replaced an A928A y-h31 transistor (it was gray-ish), only to discover it's used for overvoltage protection.

    i've remembered i have a scheme of a 200W PSU and looked into it.
    now i suspect on Schottky diode malfunction (on this 200w scheme, after schottky is only couple of coils, 2 capacitors and a resistor)

    please help me out

  2. #2
    Join Date
    Sep 2008
    Location
    Zagreb, Croatia
    Posts
    5
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default

    ok, so let me rephrase the question

    can a blown schottky diode when loaded with more than standby current cause a 1V voltage drop?

  3. #3
    Join Date
    Sep 2008
    Location
    Zagreb, Croatia
    Posts
    5
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default

    well, despite your evergrowing support, i swaped the 2 schottky diodes (3.3V and 5V are identical) and i'm now waiting for my friend to bring me the PS tester to see what happens.
    if it's the schottky that's making the problems, then the problem's supposed to be on a 3.3V line.
    If it's still on 5V line, i have to look for something else. i will then try replacing 2 caps from that schottky towards the wire

  4. #4
    Join Date
    Oct 2006
    Location
    Moderator
    Posts
    6,506
    Thanks Thanks Given 
    149
    Thanks Thanks Received 
    3
    Thanked in
    2 Posts

    Default

    Quote Originally Posted by KAMENi View Post
    well, despite your evergrowing support
    You might want to try the Badcaps.net forums... there aren't that many repair techs here.

  5. #5
    Join Date
    Sep 2008
    Location
    Zagreb, Croatia
    Posts
    5
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default

    ok, thanks

    thing is that this regional forum recommended you guys


    NHF for the quote, i was just trying to get some response from someone

  6. #6
    Join Date
    Sep 2008
    Location
    Zagreb, Croatia
    Posts
    5
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default

    just to keep you up to date, i've swapped the 2 schottkys and it didn't solve the problem.
    my next step is changing the 2 caps, but i doubt it will solve the problem aswell

    we'll see

Similar Threads

  1. Newbie with PSU repair question
    By alientrader1 in forum PC Power Supply Discussion
    Replies: 6
    Last Post: 02-12-2018, 08:59 PM
  2. Can I repair surge protector?
    By Overclocked in forum Electronic Component Discussion
    Replies: 9
    Last Post: 12-23-2017, 05:08 PM
  3. Looking to repair a PSU
    By Intrepidation in forum PC Power Supply Discussion
    Replies: 9
    Last Post: 04-08-2016, 09:32 AM
  4. chip repair
    By Monalisa in forum General PC Hardware
    Replies: 3
    Last Post: 01-23-2009, 02:32 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •