Results 1 to 3 of 3

Thread: 3 Weeks old 750ZF = dead *sad*

  1. #1
    Join Date
    Dec 2007
    Posts
    66
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default 3 Weeks old 750ZF = dead *sad*

    My 3 weeks old Silverstone 750ZF just died a few hours ago, It was running smoothly in 3 weeks straight of uptime..


    But before i knew the PSU was dead, my AVR fuse popped when i turned on the computer, so i replaced it with a new fuse ( same rating 3A ) after plugging everything i switched the main power on the PSU to 'On' and the fuse pops again.. so this time i tried to connect all of my devices 1 at a time on the avr, dsl modem,speakers,lcd and after plugging in the power cable for the CPU the fuse pops again for the 3rd time.. So i tried directly plugging the CPU to the wall outlet and i get no standby power from the motherboard or the PSU led on the rear, triple checked everything and no go.. installed my old 550Watts HEC and im back up and running. I'll be sending my PSU tom for a replacement good thing the local distributor is VERY near and warranty turn around should be fast.. hopefully over the weekend.


    Anyone got some ideas on what caused the PSU to die, my AVR is 500Watts rated and is servo type with 10 seconds delay..

  2. #2
    Join Date
    Jan 2007
    Location
    Jakarta, Indonesia
    Posts
    585
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default

    Oops, is that an ideal couple beetween a 750w high end PSU with a rather meager 500w rated AVR, especially if the load is quite high ? Personally i use TT Toughpower 700w and mate it with a 1000 w servo motor AVR, it's been a solid cooperation for almost 15 months.

  3. #3
    Join Date
    Dec 2007
    Posts
    66
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default

    I barely load up 450watts on my system, so i dont think the AVR will have any problem as it never had problems running the same system but onto a 550Watts AVR

Similar Threads

  1. PC Being Built within the next 2 weeks
    By OSIRRUS XIII in forum The Gaming Forum
    Replies: 20
    Last Post: 01-28-2011, 05:44 PM
  2. Wow 6 weeks on and still no PSU!!!
    By dogmatix in forum PC Power Supply Discussion
    Replies: 9
    Last Post: 07-09-2010, 08:38 PM
  3. HX620 or Silverstone 750ZF
    By EarlZ in forum PC Power Supply Discussion
    Replies: 11
    Last Post: 01-07-2008, 01:51 PM
  4. Three Weeks With the Ultra X3
    By theseeker in forum PC Power Supply Discussion
    Replies: 10
    Last Post: 05-21-2007, 05:40 PM
  5. What's the best way to hook up a Silverstone 750ZF?
    By Madman in forum PC Power Supply Discussion
    Replies: 11
    Last Post: 01-05-2007, 02:48 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •