Results 1 to 8 of 8

Thread: New PSU advice

  1. #1
    Join Date
    Jun 2007
    Location
    Greenville, SC
    Posts
    11
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default New PSU advice

    Hello everyone, longtime reader, first post here. I've just made some upgrades to my system and think I need a new PSU as well. The system was running alright until last night. When playing stalker, my UPS would kick on and the sytem will lock up. I disconnected some fans/dvd's and lowered my vcore and the system runs fine that way, so I suspect the PSU isn't enough. I was looking at just a 5.25" PSU like the FSP booster x3 to add to the sytem, but don't know much about them.

    specs- Abit ab9 quad gt, xeon 3060(was oc'ed to 3.6GHz at 1.5 vcore), 2 GB ddr2 800, 8800gtx, 3dvd's, 2 HDD's, x-fi, 5 120mm fans. PSU is a silverstone strider st 60f, so I thought it would handle this system.

  2. #2
    Join Date
    Oct 2006
    Location
    Romania
    Posts
    1,105
    Thanks Thanks Given 
    4
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default

    Corsair HX520/620.

  3. #3
    Join Date
    Nov 2006
    Posts
    262
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default

    Quote Originally Posted by ElasticEquator View Post
    Hello everyone, longtime reader, first post here. I've just made some upgrades to my system and think I need a new PSU as well. The system was running alright until last night. When playing stalker, my UPS would kick on and the sytem will lock up. I disconnected some fans/dvd's and lowered my vcore and the system runs fine that way, so I suspect the PSU isn't enough. I was looking at just a 5.25" PSU like the FSP booster x3 to add to the sytem, but don't know much about them.

    specs- Abit ab9 quad gt, xeon 3060(was oc'ed to 3.6GHz at 1.5 vcore), 2 GB ddr2 800, 8800gtx, 3dvd's, 2 HDD's, x-fi, 5 120mm fans. PSU is a silverstone strider st 60f, so I thought it would handle this system.
    Something seems a bit fishy here... can't put my finger on it. I woudl agree that the corsiar HX620 should be enough to power that rig but why doesn't the ST60F?
    Yin|Gigabyte GA-Z68X-UD5-B3|Swiftech XT-> GTX240 -> DDC+ w/ Petra's|2600K @ 4.8GHz |4 x 4 GB G.Skill Eco PC3-12800|Asus 7950 DirectCUII|256 GB Crucial M4|2 x 2 TB Seagate LP(Raid-0)|Seasonic M12-700|Lian-Li PC-6077B (Heavily Modded)

  4. #4
    Join Date
    Oct 2006
    Location
    Romania
    Posts
    1,105
    Thanks Thanks Given 
    4
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default

    Quote Originally Posted by Bun-Bun View Post
    ... but why doesn't the ST60F?
    Yep. Good question.
    Maybe it's something related with your OC not your PSU?

  5. #5
    Join Date
    Feb 2007
    Location
    The Netherlands
    Posts
    53
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default

    Here's some interesting info concerning the Silverstone Strider 600W (older versions):
    http://www.guru3d.com/article/content/330/6/


    Good luck!

  6. #6
    Join Date
    Jun 2007
    Location
    Greenville, SC
    Posts
    11
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default

    Thanks for the replies so far. Good article CTman, I bought this PSU about a year ago so I probably have the original version. the system ran fine with my x1900xtx but with the new video card I'm getting the lockups. I suspected th oc too burebista, still orthos stable for 24 hours though. Maybe I'll try running a molex to pci-e adapter see if that helps.

  7. #7
    Join Date
    Nov 2006
    Posts
    262
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default

    Quote Originally Posted by ElasticEquator View Post
    Thanks for the replies so far. Good article CTman, I bought this PSU about a year ago so I probably have the original version. the system ran fine with my x1900xtx but with the new video card I'm getting the lockups. I suspected th oc too burebista, still orthos stable for 24 hours though. Maybe I'll try running a molex to pci-e adapter see if that helps.
    Heh, my computer is quad thread prime95, HCI memtest, folding, just about every other thing under the sun stable... but some games still crash it... lol

    Quote Originally Posted by CTman View Post
    Here's some interesting info concerning the Silverstone Strider 600W (older versions):
    http://www.guru3d.com/article/content/330/6/


    Good luck!
    Ah so it is a rail issue then. Yeah then a corsair HX620 would work fine.
    Yin|Gigabyte GA-Z68X-UD5-B3|Swiftech XT-> GTX240 -> DDC+ w/ Petra's|2600K @ 4.8GHz |4 x 4 GB G.Skill Eco PC3-12800|Asus 7950 DirectCUII|256 GB Crucial M4|2 x 2 TB Seagate LP(Raid-0)|Seasonic M12-700|Lian-Li PC-6077B (Heavily Modded)

  8. #8
    Join Date
    Nov 2006
    Location
    In the trunk of the Lunar Rover on the moon!!
    Posts
    136
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default

    being Orthos stable is all well and good...yet is it Orthos stable say 48 hrs in......

    just asking..

    Good Luck!!

Similar Threads

  1. Advice on new PSU
    By mrllama in forum PC Power Supply Discussion
    Replies: 10
    Last Post: 03-31-2017, 09:02 AM
  2. PSU Advice
    By PleaseHelpANoob in forum PC Power Supply Discussion
    Replies: 3
    Last Post: 02-16-2016, 02:13 PM
  3. New pc need advice
    By smogsy in forum PC Power Supply Discussion
    Replies: 12
    Last Post: 08-21-2007, 05:37 PM
  4. little advice
    By line6 in forum PC Power Supply Discussion
    Replies: 3
    Last Post: 08-17-2007, 06:51 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •