Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: Corsair TX850M / Doubt about ATX12V/EPS12V Cable

  1. #11
    Join Date
    Mar 2020
    Location
    Portugal
    Posts
    5
    Thanks Thanks Given 
    7
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default

    Hi,

    Thanks to both, tomorrow i'll check the voltages and reply, in case this is useful to anyone else.

    I'm not asking about the cable and the opinion about the HX1000 because of this setup only, right now a Threadripper is out of equation because of the cost but in a near future i might go for one.
    If the HX1000 doesn't act weird, i might use it in the Threadripper build. (i didn't use it now because of the pains of disassembling another build with 2 WC loops)

    Thanks a lot.

  2. #12
    Join Date
    Mar 2020
    Location
    Portugal
    Posts
    5
    Thanks Thanks Given 
    7
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default

    Hi,

    Just an update:

    I emailed Corsair complaining about not having an extra EPS12V cable and they will send me one free of charge as an one-time-courtesy .

    When i get the results from the HX1000 cable i'll post them.

    Greats.

  3. #13
    Join Date
    Oct 2006
    Location
    jonnyGURU forums, of course!
    Posts
    16,665
    Thanks Thanks Given 
    565
    Thanks Thanks Received 
    438
    Thanked in
    330 Posts

    Default

    Quote Originally Posted by MinisterOfSound View Post
    Hi,

    Just an update:

    I emailed Corsair complaining about not having an extra EPS12V cable
    Why did you complain? It's not like the PSU was supposed to come with a second EPS12V cable.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •