Results 1 to 3 of 3

Thread: Seasonic Titanium 1000 made a clicking sound while running OCCT

  1. #1
    Join Date
    Apr 2009
    Location
    Worcester, MA
    Posts
    43
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default Seasonic Titanium 1000 made a clicking sound while running OCCT

    Hi,

    Was running OCCT stability tester the other night and heard a clicking sound coming from inside my pc.
    Think it was coming from the PSU area and it sounded like that sound old hard drives use to make.
    Went away after turn off Hybrid mode and turning on the fan on the PSU.

    Hope it was just my imagination. Think I need to RMA it?

    Thanks

  2. #2
    Join Date
    Aug 2017
    Location
    Australia
    Posts
    54
    Thanks Thanks Given 
    14
    Thanks Thanks Received 
    5
    Thanked in
    4 Posts

    Default

    Could've been in the specific load between the the PSU's fans passive and active mode.

  3. #3
    Join Date
    Oct 2006
    Location
    jonnyGURU forums, of course!
    Posts
    16,183
    Thanks Thanks Given 
    544
    Thanks Thanks Received 
    301
    Thanked in
    218 Posts

    Default

    Quote Originally Posted by Rexper View Post
    Could've been in the specific load between the the PSU's fans passive and active mode.
    Assuming it's the fan. Could be a magnetic (coil, transformer, etc.)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •