Results 1 to 5 of 5

Thread: problem connecting 8 pin cpu connector to motherboard with psu running

  1. #1
    Join Date
    Aug 2011
    Location
    phoenix,az
    Posts
    138
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default problem connecting 8 pin cpu connector to motherboard with psu running

    well, my nightmare is done , when connecting the 8pin cpu connector on system board with the psu running , and heard a loud snap noise..did damage..

    i ended up buying a new cpu, it destroyed the cpu that was in the previous motherboard when i connected 8pin cpu connector to systemboard with psu running.. when i have the cpu installed,..it will not boot to post, and even the lights on the keyboard do not work....installed the new cpu i bought, it boots right up....

    this was a expensive mistake.....its cost me money for a new cpu, and i got a new motherboard..it also did something to the case, the power button will not come on, bought a new case......so it was $400 dollar mistake....OUCH

  2. #2
    Join Date
    Aug 2010
    Posts
    2,700
    Thanks Thanks Given 
    116
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default

    NEVER connect/disconnect any PSU connectors in your PC while PSU is running.

    That's absolute.

  3. #3
    Join Date
    Jul 2009
    Location
    Germany
    Posts
    3,409
    Thanks Thanks Given 
    6
    Thanks Thanks Received 
    12
    Thanked in
    10 Posts

    Default

    Why would you do that??

  4. #4
    Join Date
    Oct 2017
    Location
    Grand Junction, CO
    Posts
    1,584
    Thanks Thanks Given 
    61
    Thanks Thanks Received 
    5
    Thanked in
    5 Posts

    Default

    Fatigue?

  5. #5
    Join Date
    Nov 2018
    Location
    usa
    Posts
    8
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default

    awww charge to experience bro.

Similar Threads

  1. Replies: 6
    Last Post: 07-18-2018, 12:56 PM
  2. Replies: 14
    Last Post: 06-26-2018, 11:20 AM
  3. Running a Phenom II X6 1090 on a single EPS connector blew the PSU
    By geoalbi in forum PC Power Supply Discussion
    Replies: 13
    Last Post: 01-21-2018, 04:42 AM
  4. Seasonic X-650 24 pin motherboard connector
    By QuadSSD in forum PC Power Supply Discussion
    Replies: 6
    Last Post: 12-12-2011, 07:30 AM
  5. Power supply motherboard connector
    By maxusmag in forum PC Power Supply Discussion
    Replies: 4
    Last Post: 05-10-2008, 05:53 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •