Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Cooler Master Real Power Pro 1000W PSU 10 Year Redux

  1. #1
    Join Date
    Oct 2006
    Location
    Moderator
    Posts
    4,122
    Thanks Thanks Given 
    19
    Thanks Thanks Received 
    12
    Thanked in
    5 Posts

    Default Cooler Master Real Power Pro 1000W PSU 10 Year Redux

    I don't usually, or ever, pimp shit but I thought this might be of interest (https://www.hardocp.com/article/2018...0_year_redux/1) since the last one was (http://www.jonnyguru.com/forums/show...verstone+redux).

  2. The Following 3 Users Say Thank You to Spectre For This Useful Post:

    GDILord (03-13-2018), Tator Tot (03-12-2018), turkey3_scratch (03-12-2018)

  3. #2
    Join Date
    May 2010
    Location
    Missouri; USA
    Posts
    5,028
    Thanks Thanks Given 
    408
    Thanks Thanks Received 
    8
    Thanked in
    5 Posts

    Default

    Definitely a very interesting set of results. Would be nice to know what exactly was causing the unit to shut down on the full load tests.

  4. #3
    Join Date
    Oct 2006
    Location
    Moderator
    Posts
    4,122
    Thanks Thanks Given 
    19
    Thanks Thanks Received 
    12
    Thanked in
    5 Posts

    Default

    Quote Originally Posted by Tator Tot View Post
    Definitely a very interesting set of results. Would be nice to know what exactly was causing the unit to shut down on the full load tests.
    No obvious failures. +5vsb was still viable but that was it.

  5. #4
    Join Date
    Jul 2009
    Location
    Germany
    Posts
    3,445
    Thanks Thanks Given 
    6
    Thanks Thanks Received 
    19
    Thanked in
    17 Posts

    Default

    Maybe a faulty shunt?
    Have you tried loading each +12V Rail individually or change the load on it?

  6. #5
    Join Date
    Oct 2006
    Location
    Moderator
    Posts
    4,122
    Thanks Thanks Given 
    19
    Thanks Thanks Received 
    12
    Thanked in
    5 Posts

    Default

    Quote Originally Posted by Stefan Payne View Post
    Maybe a faulty shunt?
    Have you tried loading each +12V Rail individually or change the load on it?
    Shutdown the first time it was tried. No load pattern after it shutdown would let it turn back on.

  7. #6
    Join Date
    Oct 2006
    Location
    jonnyGURU forums, of course!
    Posts
    15,577
    Thanks Thanks Given 
    506
    Thanks Thanks Received 
    56
    Thanked in
    46 Posts

    Default

    And this is why PSU reviews are subjective after all.

    I see more "great" PSUs fail over time due to design decisions than I see fail because of shit parts.

    Loved the TTGI throwback by the way.

  8. #7
    Join Date
    Oct 2006
    Location
    Moderator
    Posts
    4,122
    Thanks Thanks Given 
    19
    Thanks Thanks Received 
    12
    Thanked in
    5 Posts

    Default

    Quote Originally Posted by jonnyGURU View Post
    Loved the TTGI throwback by the way.
    Would you have guessed that unit would have survived that long? LOL

  9. #8
    Join Date
    Nov 2015
    Location
    U.S.A.
    Posts
    1,264
    Thanks Thanks Given 
    327
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default

    Thanks for the review Spectre! This and the Silverstone reviews seem to confirm more people's general notions when they speak about "power supplies losing power over their time - granted, I really dislike the vocabulary people use when speaking of this, since I consider it to be the failure of a component at a lower-than-before power level rather than fundamental loss of power. But regardless...

    When you do load tests, do you generally switch it from 75% to 100% immediately, causing a transient, or do you slowly increase it from 75% to 100%? If the latter, do you happen to know at about what percentage it shut off at? If it was to shut off at 78% load, that'd be a significant detail versus if it shut off at 97% load.

  10. #9
    Join Date
    May 2010
    Location
    Missouri; USA
    Posts
    5,028
    Thanks Thanks Given 
    408
    Thanks Thanks Received 
    8
    Thanked in
    5 Posts

    Default

    Forgot to ask Paul, but did you look inside the unit, how bad were the dust bunnies?

  11. #10
    Join Date
    May 2016
    Location
    South Africa
    Posts
    130
    Thanks Thanks Given 
    287
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default

    Thanks for the review, Spectre. I enjoyed reading it. :-)

Similar Threads

  1. SilverStone Olympia 1000W Power Supply 7 Year Redux
    By -The_Mask- in forum PC Power Supply Discussion
    Replies: 36
    Last Post: 03-15-2018, 02:19 AM
  2. Cooler Master Silent Pro M 1000W redux
    By ehume in forum PC Power Supply Discussion
    Replies: 3
    Last Post: 07-13-2012, 08:17 PM
  3. Cooler Master Real Power M620 OEM?
    By crmaris in forum PC Power Supply Discussion
    Replies: 2
    Last Post: 06-12-2010, 07:53 AM
  4. Cooler Master Real Power Pro 1000W Review
    By SKYMTL in forum PC Power Supply Discussion
    Replies: 18
    Last Post: 08-08-2007, 03:40 PM
  5. Cooler Master Real Power Pro 1000W $189+shipping
    By Nicepants42 in forum Hot Deals
    Replies: 0
    Last Post: 08-08-2007, 03:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •