Results 1 to 6 of 6

Thread: Rapid Clicking with S12II 520W

  1. #1
    Join Date
    Dec 2017
    Location
    Vancouver, BC
    Posts
    8
    Thanks Thanks Given 
    1
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default Rapid Clicking with S12II 520W

    Hi all,

    Owner of a S12II 520 watt power supply bought in 2012. For the past six months, the PSU has developed a rapid clicking noise, identical to the audio recorded on this video: https://www.youtube.com/watch?v=3J4WsZ_gfTk

    I have confirmed that the noise originates from the PSU because it is still present even when the CPU and case fans are unplugged. It also occurs when the PSU fan is halted.

    I don't think it is coil whine because it is much more louder—audible even when standing across the room—and occurs even when the computer is idle. The clicking becomes more rapid when the computer is under a heavier load.

    There are various reports from around the web addressing this same issue with both the S12II and M12II:
    https://www.eevblog.com/forum/repair...-pc-psu-noise/
    http://www.tomshardware.com/answers/...orks-fine.html
    https://www.reddit.com/r/techsupport..._a_very_quiet/
    There doesn't appear to be a consensus on the cause. The thread at the first link claims it is an issue with the PFC circuit. The others threads fault bad capacitors, which I don't think is true in this case.

    Is this a known issue with the S12II and M12II lines? Any insights what is causing it?

  2. #2
    Join Date
    Jun 2010
    Location
    The Netherlands
    Posts
    5,095
    Thanks Thanks Given 
    367
    Thanks Thanks Received 
    19
    Thanked in
    19 Posts

    Default

    That's coil whine, could be from a X capacitor or coil on the primary side of the power supply. Or it's the problem from that video, which can be fixed as shown in the description.

  3. #3
    Join Date
    Sep 2016
    Location
    VN
    Posts
    150
    Thanks Thanks Given 
    14
    Thanks Thanks Received 
    1
    Thanked in
    1 Post

    Default

    Have several style of clicking noise
    But in S12II M12II 430-620 platform . most of case is PFC control circuit have problems ( small board sit near bulk capacitor ) if you have power meter you can see PF only 0.5 0.6 (normal is 0.8 09 in medium load) . you can reflow all smd component in this board . sometime it can solve problems.

  4. #4
    Join Date
    Dec 2017
    Location
    Vancouver, BC
    Posts
    8
    Thanks Thanks Given 
    1
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default

    The same issue exists with other model lines. Here, I've filmed an old SS-400HT with the same type of noise.
    https://photos.app.goo.gl/C8SURnIzg8oWUuEu1

    Should say that it's much louder in my S12II unit.

  5. #5
    Join Date
    Dec 2017
    Location
    Vancouver, BC
    Posts
    8
    Thanks Thanks Given 
    1
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default

    I did some additional testing of the S12II unit over the holidays and discovered a curious side-effect. When the PSU was switched on, I noticed that a fluorescent lamp in the same room was pulsing in time with the clicks.

    To investigate further, I plugged a multimeter set to frequency mode into the same powerbar as the PSU. When the PSU is off the frequency holds steady at 60 Hz. When turned on, the frequency jumps around rapidly.

    Video here: https://photos.app.goo.gl/WXeeSH3EK2JXiG713

    When I redid the test with another PSU, the multimeter reading stayed at 60 Hz. This seems to confirm that the clicking issue is somehow connected to the PFC circuit.

  6. The Following 2 Users Say Thank You to Variable For This Useful Post:

    Al3xand3r (01-04-2018), Per Hansson (01-05-2018)

  7. #6
    Join Date
    Sep 2017
    Location
    Romania
    Posts
    226
    Thanks Thanks Given 
    95
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default

    Good job! That PSU is not safe to use anymore. You should RMA it.
    Definitley there is a problem with the APFC or the EMI filter of that PSU imo.

Similar Threads

  1. PSU without clicking sound?
    By monsterenergy22 in forum PC Power Supply Discussion
    Replies: 12
    Last Post: 05-22-2017, 04:56 PM
  2. Intel Rapid Storage Technology..question.
    By Baron in forum General PC Hardware
    Replies: 1
    Last Post: 08-01-2016, 09:58 AM
  3. Seasonic s12ii 520w vs antec truepower c 750
    By jliang in forum PC Power Supply Discussion
    Replies: 22
    Last Post: 03-24-2016, 08:33 PM
  4. Seasonic S12II 430W or 520W
    By kekarot in forum PC Power Supply Discussion
    Replies: 32
    Last Post: 11-01-2015, 05:16 PM
  5. PSU clicking noise
    By kollapse in forum PC Power Supply Discussion
    Replies: 1
    Last Post: 11-15-2008, 03:18 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •