Results 1 to 6 of 6

Thread: What happened to Xbit Labs?

  1. #1
    Join Date
    Oct 2016
    Location
    Brazil
    Posts
    206
    Thanks Thanks Given 
    177
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default What happened to Xbit Labs?

    I know they stopped to publish anything since 2014, howeve, they maintained the website alive.

    It seems something happened, because it's inaccessible in the past ~3 weeks...

  2. #2
    Join Date
    Jun 2016
    Location
    Australia
    Posts
    166
    Thanks Thanks Given 
    327
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default

    I guess in that case it has died at last

  3. #3
    Join Date
    Oct 2016
    Location
    Brazil
    Posts
    206
    Thanks Thanks Given 
    177
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default

    That's really sad, they had a lot of interesting articles...

    At least it's possible to see the content through the Wayback Machine.

  4. #4
    Join Date
    Oct 2006
    Location
    jonnyGURU forums, of course!
    Posts
    16,070
    Thanks Thanks Given 
    538
    Thanks Thanks Received 
    274
    Thanked in
    198 Posts

    Default

    They stopped reviews almost a decade ago. The forums were kept alive, but I guess someone offered to buy the domain or someone else owned the name or something because recently (last month) they moved the forums here: http://xbitlabs.prophpbb.com/

    EDIT:
    The site's Co-founder, Ilya ( Gavric ) has been paying for the hosting costs of the old site and these forums all by himself for the past year. He has a new job, but since the value of the Russian Ruble is so low lately the hosting costs have become too much for him to keep on going at this point.

  5. The Following 2 Users Say Thank You to Jon Gerow For This Useful Post:

    Internet (02-20-2017), quest for silence (02-22-2017)

  6. #5
    Join Date
    Oct 2016
    Location
    Brazil
    Posts
    206
    Thanks Thanks Given 
    177
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default

    Quote Originally Posted by jonnyGURU View Post
    They stopped reviews almost a decade ago.
    Almost a decade? They had reviews until 2014, they reviewed the GTX 980, the Haswell-E CPUs, also a lot of PSUs...


    Quote Originally Posted by jonnyGURU View Post
    The forums were kept alive, but I guess someone offered to buy the domain or someone else owned the name or something because recently (last month) they moved the forums here: http://xbitlabs.prophpbb.com/

    EDIT:
    Ah, thanks for pointing the new link. Saved.

  7. #6
    Join Date
    Oct 2006
    Location
    jonnyGURU forums, of course!
    Posts
    16,070
    Thanks Thanks Given 
    538
    Thanks Thanks Received 
    274
    Thanked in
    198 Posts

    Default

    Quote Originally Posted by Internet View Post
    Almost a decade? They had reviews until 2014, they reviewed the GTX 980, the Haswell-E CPUs, also a lot of PSUs...
    You know what.. I was thinking about when they were down for an extended period of time due to a DDoS attack.

Similar Threads

  1. IKONIK Power Supply Units Roundup at XBit Labs
    By burebista in forum PC Power Supply Discussion
    Replies: 3
    Last Post: 07-16-2009, 09:38 PM
  2. PSU's roundup at XBit Labs
    By burebista in forum PC Power Supply Discussion
    Replies: 17
    Last Post: 09-16-2007, 03:17 AM
  3. what happened to plextor?
    By tobrien in forum General PC Hardware
    Replies: 15
    Last Post: 09-15-2007, 02:39 PM
  4. 1kW PSU roundup at XBit Labs
    By Super Nade in forum PC Power Supply Discussion
    Replies: 26
    Last Post: 05-04-2007, 10:14 PM
  5. Great review about PSU from X-bit labs.
    By burebista in forum PC Power Supply Discussion
    Replies: 17
    Last Post: 11-23-2006, 04:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •