Results 1 to 4 of 4

Thread: Anybody with experience repairing those damn Enermax units refusing to turn on?

  1. #1
    Join Date
    Aug 2013
    Location
    50°4'53.169"N, 14°23'30.699"E
    Posts
    1,578
    Thanks Thanks Given 
    90
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default Anybody with experience repairing those damn Enermax units refusing to turn on?

    Frankly I don't get so many units refusing to turn on from any other manufacturer than Enermax which I cannot repair. Ppl often do not care about warranty papers believing Enermax won't die, why bother? yet they are dropping like flies. And I am tralking about high-end units beginning with Liberty-spinoffs to Revolution 87+. Enermax stoped RMAing unless you have some paper in hand, wonder how much of their loss for last 5 years is because of RMA'd units. Many of these go bad between 4th-5th year.

    Anyway, in most cases the problem is it refuses to start. Often it just twitches the fan, units with after-cooling than spin the fan for another minute before turning off. Latest one is MODU 87+ (EMG500AWT) which does nothing at all up shorting PWR_On, roughly 5 years old.

    It was never bad power silicon, never capacitors, I always got +5 V SB and PWR_On voltage as they should be. Problem is probably somewhere around the monitor, feedback or driving circuitry, but where Anybody has any idea?

  2. #2
    Join Date
    Jun 2010
    Location
    The Netherlands
    Posts
    5,119
    Thanks Thanks Given 
    367
    Thanks Thanks Received 
    27
    Thanked in
    27 Posts

    Default

    Glue that got conductive?

    Maybe try to measure the inputs from the monitoring IC to see which protection gets triggered.

  3. #3
    Join Date
    Aug 2013
    Location
    50°4'53.169"N, 14°23'30.699"E
    Posts
    1,578
    Thanks Thanks Given 
    90
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default

    There is no chloroprene glue for many years, if something than Enermax used silicon after that experience with Liberty.

    Forgot to mention, monitor is Silicon Touch PS231. There is no protection kicking in, it does not even react on the PWR On signal.

    I am not in the workplace ATM but I'll first check whether it even gets Vcc and if so than the fault protection output pin (FPO/Open Drain Digital Output). Seems that this one also makes the power on output to tell the rest of the circuitry to start working

  4. #4
    Join Date
    Jan 2010
    Location
    Greece
    Posts
    1,525
    Thanks Thanks Given 
    178
    Thanks Thanks Received 
    5
    Thanked in
    2 Posts

    Default

    had one Enermax in the past, several years ago, that didn't start. I couldn't, for the world, make it operate again. I even sent it to a lab to take a look at, because I was really curious to find out the problem, and they couldn't do anything with it.

Similar Threads

  1. Enermax Power Supply Units Roundup
    By burebista in forum PC Power Supply Discussion
    Replies: 1
    Last Post: 01-23-2009, 04:53 PM
  2. Does someone know about Enermax's entry-level 80+ units?
    By Travis in forum PC Power Supply Discussion
    Replies: 10
    Last Post: 12-29-2008, 09:29 PM
  3. Some discovery about OCZ and Enermax units
    By Travis in forum PC Power Supply Discussion
    Replies: 18
    Last Post: 12-29-2008, 09:25 AM
  4. L&C UL number E214301 -- Any experience with any of their units?
    By dnorf87 in forum PC Power Supply Discussion
    Replies: 7
    Last Post: 08-06-2007, 02:23 PM
  5. Damn we're good!
    By SuperSix in forum Off Topic
    Replies: 4
    Last Post: 02-08-2007, 11:14 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •