Results 1 to 3 of 3

Thread: NDFAQs claims charset=ISO-8859-1, but is UTF-8

  1. #1
    Join Date
    Oct 2007
    Posts
    446
    Thanks Thanks Given 
    21
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default NDFAQs claims charset=ISO-8859-1, but is UTF-8

    For example, the quote marks around efficiency are encoded as e2 80 9c and e2 80 9d, which are valid UTF-8 for U+201C and U+201D. But 0x80 isn't even a valid ISO-8859 character.

    (Interestingly, the web server appears to not like wget, and returns 404 to a request to "wget http://www.jonnyguru.com/modules.php?name=NDFAQs", but happily serves it up if I tell wget to not send a User-Agent string.)

  2. #2
    Join Date
    Oct 2006
    Location
    jonnyGURU forums, of course!
    Posts
    16,070
    Thanks Thanks Given 
    538
    Thanks Thanks Received 
    274
    Thanked in
    198 Posts

    Default

    That happened when we copied and pasted content out of the original backend and into the new one. I wish I could remember why, but there are some reviews that have that mistake as well.

  3. #3
    Join Date
    Oct 2006
    Location
    GURU-ville
    Posts
    1,312
    Thanks Thanks Given 
    48
    Thanks Thanks Received 
    26
    Thanked in
    7 Posts

    Default

    I would say the quote issue probably happened when we made the recent server change. I've found in the past, that migrating from one to another occasionally gives us this result. What's odd is why it only does it on certain ones and not others. We've seen it a lot when we copy over some of the tables in the past as well.

    On the charset side of it. I don't really have an answer for why its giving you ISO-8859-1. I keep getting closer and closer to having someone recode the front end completely so that we can get away from the open source CMS that I originally started with.
    Last edited by Tazz; 05-17-2013 at 06:36 AM.

Similar Threads

  1. Fractal Design under fire for false claims
    By Jon Gerow in forum PC Power Supply Discussion
    Replies: 16
    Last Post: 05-03-2013, 01:09 AM
  2. Say what? Driver Heaven claims the TX650 is made by CWT
    By HOOfan_1 in forum PC Power Supply Discussion
    Replies: 12
    Last Post: 03-02-2008, 07:58 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •