View Single Post
  #1  
Old 02-05-2012
Bun-Bun Bun-Bun is offline
1kW User
 
Join Date: Nov 2006
Posts: 262
Thanks: 0
Thanked 0 Times in 0 Posts
Default Corsair HX620 died... then came back to life

As seems to be all my computer experiences I have have another weird one.

Crucial M4 SSD's had a important F/W update. Pull side panel off, unplug other HDD's. Power up with F/W update, flash SSD, turn off. Plug HDD's back in. Turn on computer. Everything is booting fine. Put side panel back on and computer goes dead as soon as the side panel touches the case... wtf?

Computer will no longer turn on. Power light blips and then nothing. Get out PSU tester... nothing. USB devices still have power so the unit isnt completely dead... just wont turn on.

Frustrated I connect a cheapo 500w coolermaster to the computer and it runs fine for a week while I order a Corsair HX650.

Go to put in the HX650 and I decide to test the HX620 one last time and the darn thing is now working but the fan is clicking a bit. The computer is incredibly dusty (as my dad is a heavy smoker) so I take it out to the garage and blow it completely out. Now the airflow is greatly improved and the fan in the PSU no longer clicks.


Question: Would you trust this PSU? Did it just overheat from too much dust? Or would a safety trip from not having the fan running at speed?
__________________
Yin|Gigabyte GA-Z68X-UD5-B3|Swiftech XT-> GTX240 -> DDC+ w/ Petra's|2600K @ 4.8GHz |4 x 4 GB G.Skill Eco PC3-12800|Asus 7950 DirectCUII|256 GB Crucial M4|2 x 2 TB Seagate LP(Raid-0)|Seasonic M12-700|Lian-Li PC-6077B (Heavily Modded)
Reply With Quote